Προβλήματα (bugs) και λύσεις στην openSUSE 12.3

by 9:57 μ.μ. 1 σχόλια


Πριν λίγο καιρό είχαμε στα χέρια μας την έκδοση openSUSE 12.3. Την εγκαταστήσαμε γεμάτοι χαρά, αλλά με μεγάλη μας λύπη, αντιμετωπίσαμε ορισμένα προβλήματα. Ποια είναι αυτά; Θα δούμε εδώ μερικά και θα δούμε τις προσωρινές λύσεις. Πιθανό να υπάρχουν και άλλα. Θα τα μάθουμε με την χρήση.

1. Επιλογή Ελληνικής γλώσσας κατά την εγκατάσταση.

Κατά την εγκατάσταση, αν επιλέξετε Ελληνικά ως γλώσσα εγκατάστασης και πληκτρολογίου, θα έχετε την παρακάτω εικόνα (με κόκκινο είναι τα σφάλματα):

openSUSE 12.3 language bug


Τελευταία έκδοση που η Ελληνική γλώσσα έμπαινε από την αρχή ήταν η έκδοση 11.4. Από τις εκδόσεις 12.1 και μετά αντιμετώπιζα το ίδιο πρόβλημα. Το ανέφερα στις λίστες και στο wiki αλλά μάλλον δεν ασχολήθηκε κανείς. Πρόσφατα το ανέφερα ως bug στο BUGZILLA. Μάλιστα κάποιος ανέφερε ότι αυτό παίζει να είναι 32bit bug μόνο. Δεν είχα 64bit σύστημα να το δοκιμάσω. Επίσης το εγκατέστησα και από DVD, μπας και αλλάζει στα Ελληνικά αλλά μ την ίδια τύχη.

Η λύση στο συγκεκριμένο πρόβλημα είναι η επιλογή Αγγλικής γλώσσας στην αρχή:

openSUSE 12.3 choose English


Όταν εγκατασταθεί πλήρως το σύστημά σας, αλλάξτε την γλώσσα μέσα από το YaST (όπως φαίνεται παρακάτω):

openSUSE 12.3 YaST change language


Αποσυνδεθείτε και συνδεθείτε ξανά. Στη συνέχεια από το System Settings (GNOME), προσθέστε Ελληνικά.

openSUSE 12.3 System Settings change language


Αποσυνδεθείτε και συνδεθείτε ξανά.

Τώρα θα τα βλέπετε όλα Ελληνικά.
Σε περίπτωση που κάνατε το λάθος και εγκαταστήσατε από την αρχή Ελληνικά, πρέπει να μπείτε στο YaST, να το γυρίσετε στα Αγγλικά, αποσύνδεση και επανασύνδεση. Στη συνέχεια, θα κάνετε την παραπάνω διαδικασία για να μπουν τα Ελληνικά.

2. Εναλλαγή γλώσσας ALT+Shift στο GNOME.

Στο GNOME 3.6, δεν χρησιμοποιείται το Shift για αλλαγή γλώσσας. Δυστυχώς έχουν αλλάξει αρκετές επιλογές και δεν υπάρχει η ρύθμιση μέσα από το System Settings>Keyboard. Αυτό πρέπει να γίνει μέσα από το gnome-tweek-tool. Θα πάτε στο Πληκτρολόγηση (Typing) και ρυθμίστε το Modifiers-only input sources να είναι Alt Shift όπως στην εικόνα.

openSUSE 12.3 Alt Shift Solution


Αυτό το πρόβλημα είναι του GNOME. Την ίδια λύση δίνουν και στο Fedora 18. Αν δεν κάνω λάθος, το έχουν δηλώσει και στο bugzilla αλλά είναι πρόβλημα του GNOME και όχι κάποιας διανομής.

3. Κατάρρευση του yast-gtk.

Όπως πιθανό να γνωρίζετε, χρησιμοποιώ GNOME. Το GNOME χρησιμοποιεί το yast-gtk. Δοκίμασα να εγκαταστήσω τα codecs με την χρήση ymp αρχείου από την παρακάτω διεύθυνση.

http://opensuse-community.org/codecs-gnome.ymp

Το αποτέλεσμα που πήρα ήταν η παρακάτω οθόνη:

openSUSE 12.3 yast-gtk bug


Το ίδιο πρόβλημα εμφάνισε και φίλος όταν έκανε εγκατάσταση προγραμμάτων και τελικά το αντικατέστησε με το KDE. Ψάχνοντας το BUGZILLA, βρήκα το σφάλμα 808076 καθώς και το 779821.

Σκέφτηκα λοιπόν να αντικαταστήσω το yast-gtk με το yast-qt. Οι φίλοι με KDE μου λένε ότι σε αυτούς δουλεύει μια χαρά. Αντικατέστησα μέσα από το yast, το pattern-gnome-yast με το pattern-kde4-yast και μετά από επανεκκίνηση, δοκίμασα να εγκαταστήσω τα codecs αλλά πήρα το ίδιο αποτέλεσμα. Την λύση την βρήκα στο forum μετά από παρότρυνση φίλου. Ανοίγω λοιπόν το yast και το etc/sysconfig και μπήκα στο system/yast2/wanted_GUI και επιλέγω qt.

openSUSE 12.3 yast-gtk bug


Εναλλακτικά μπορείτε να επιλέξετε και ncurses και θα ανοίγει στο τερματικό. Με αυτόν τον τρόπο δεν θα έχετε καμία κατάρρευση.
Μετά από αυτό, δοκίμασα να εγκαταστήσω τα codecs και εγκαταστάθηκαν με επιτυχία.

Efstathios Iosifidis

openSUSE and GNOME foundation member

I'm Farm Animal Manager and dairy products technician looking for new opportunities.

1 σχόλιο:

  1. Το πρόβλημα με την σωστή εφαρμογή/εγκατάσταση της ελληνικής γλώσσας στο λειτουργικό σύστημα το πρόσεξα και εγώ, είτε στο opensuse με kde είτε στο opensuse με xfce. Μισα ελληνικά μισά αγγλικά τα εμφάνιζε, βασικά τα πιο πολλά στα αγγλικά ήταν και αυτό δεν μου άρεσε.

    Θέλω να επιβεβαιώσω δύο πράγματα:

    1. Η λύση που προτείνεις πράγματι δουλεύει και λύνει το πρόβλημα.

    2. Αυτός που σου ανέφερε ότι μάλλον είναι 32bit bug μόνο κάνει λάθος. Εγώ έχω 64bit σύστημα. Κατέβασα το 64bit DVD από την ιστοσελίδα και έκανα εγκατάσταση το 64bit σύστημα και παρ' όλα αυτά αντιμετώπισα το πρόβλημα που είχες και εσύ. Επομένος το πρόβλημα είναι και σε 32bit και σε 64bit. Πρέπει να λυθεί οπωσδήποτε αυτό και πρέπει οπωσδήποτε να δώσουν σημασία σε αυτό οι developers γιατί είναι ενοχλητικό bug το οποίο δεν αφήνει και τις καλύτερες εντιπώσεις.

    ΑπάντησηΔιαγραφή